CommentLuv Problem mit AntispamBee – LÖSUNG

CommentLuv und AntispamBee LogoVor ein paar Tagen habe ich den WordPress Kommentar-Spamschutz Askimet gegen AntispamBee von Sergej Müller ausgetauscht. Grund dafür war folgender: Bei mir stand unter jedem Kommentar wenn ich auf bearbeiten klicke „Akismet hat diesen Kommentar blockiert“ obwohl der Kommentar ganz normal genehmigt wurde und angezeigt wird. Keine Ahnung warum dann dieser Hinweis da stand. Deshalb habe ich in verschiedenen WordPress Foren um Hilfe gefragt, ob jemand seine Bedeutung weiß oder wie ich diesen Hinweis weg bekomme. Eine nette Antwort war z.B. „wechsle von Askimet zu Antispam Bee. Das schafft dir Probleme mit dem Datenschutz vom Hals, kommuniziert nicht mit irgendwelchen Servern, filtert besser und produziert keine eigenartigen Mitteilungen.“ Gesagt, getan…

Eigentlich funktionierte Askimet ja ohne Probleme, doch die Datenschutz Probleme wollte ich umgehen und diese eigenartige Mitteilung, dass Askimet den Kommentar blockiert hat, störte mich auch ein wenig. Also musste es weg. Ich deaktivierte daraufhin Askimet und installierte das Plugin Antispam Bee und aktivierte es. Ein paar kleine Änderungen in den Einstellungen und schon machte es das was ich wollte. Allerdings stellt ich ein paar Tage später ein kleines Designproblem an den CommentLuv Links fest und konnte ausmachen, dass es am neuen AntispamBee lag.

Diese harmonierten nicht richtig miteinander und ich hab daraufhin eine Mail an Sergej Müller und das Support Team von Zendesk geschickt. Durch diese Mail wurde ein Request mit meinen Mailtext und den beiden angehängten Bildern (siehe weiter unten) auf dem Zendesk Support Forum angelegt. Nach kurzer Zeit bekam ich auch schon einen ersten Hilfevorschlag von Andy Bailey (CommentLuv Autor), der aber nicht zum Erfolg führte. Beim zweiten Anlauf hatten wir dann das Problem gelöst. Wer sich dafür interessiert und auch dieses Problem hat, sollte sich den folgenden Lösungsvorschlag durchlesen:

Jörg Klopsch Jörg Klopsch
21 Apr 14:03 YEAAAAAAHHHHHH! That’s it! It works perfect!Many thanks for your good and detailed helping! You are great! *happy*

 

Andy Baile Andy Bailey (CommentLuv)
21 Apr 13:51 look at the bottom for the red bar marked technical settings. click that it and opens up the place where you edit the technical settings like comment textarea name

 

Jörg Klopsch Jörg Klopsch
21 Apr 13:40 I dont know where i must add d14df-comment in the commentluv settings. I have opened the settings of commentluv, but there is no field for a comment name or something else. Can you explain me, where in the settings i can add this name ?

 

Andy Baile Andy Bailey (CommentLuv)
21 Apr 13:24 the problem lies with spambee adding css to style the spans in the comment also it adds a new name for the text area, it is set to d14df-comment but you need to add that name in to the commentluv settings so it knows where the comment text area is. try adding d14df-comment as the comment name in the commentluv settings then make sure you clear all caches and hard refresh the page (ctrl+f5) and check

 

Jörg Klopsch
21 Apr 11:40 Hello Andy, thank you for your comment answer. I have added this in the Stylesheet (style.css) of my theme. But without result. The CommentLuv Links are still displayed wrong. After trying that code i have deleted it from stylesheet again.

 

Andy Baile Andy Bailey (CommentLuv)
21 Apr 11:07 try adding this to the end of your stylesheetform #lastposts { width: 100% } see if that helps Kind regards CommentLuv Support

 

Jörg Klopsch Jörg Klopsch
21 Apr 08:58 Hello Sergej Müller and Support Team from Zendesk,i have a compatibility problem between the following two plugins CommentLuv and Antispam Bee. I use WordPress 3.9 „Smith“.When i disable the Antispam Bee Plugin from Sergej Müller, the CommentLuv Links will be shown correctly (see picture commentluv_without_antispambee.jpg). When i activate Antispam Bee the CommentLuv Links looks not so good (see picture commentluv_with_antispambee.jpg). Ok, the links can be choosen and they work, but they are looking not so good in the drop down menu. 🙁

I have discovered the problem until today, because i installed AntispamBee yesterday. The hole time before, i used Askimet against spam fighting. And with Askimet the links looks good, i had have no problems with it. But a other WordPress user has recommended me Antispam Bee, so i have disabled Askimet and i have installed Antispam Bee to try it out.I hope you understand the problem and my broken english. It is only school english and i used the google translator. Would be fine when the two plugins will be work together in future, it’s just a little tip for future plugin updates.

The blog in which i have found the problem is called www.jkl-solutions.de (WordPress 3.9 „Smith“)

Und so sah das Problem aus, das ich gemeint habe. Oben hatte ich es beschrieben mit „ein kleines Designproblem“ zwischen CommentLuv und AntispamBee. Wie man sehen kann, werden auf dem rechten Screenshot die CommentLuv Links nicht richtig angezeigt. Das Problem liegt nach Aussage von Andy Bailey (Autor von CommentLuv) bei AntispamBee, welches CSS zu dem Style hinzufügt. Über obigen Lösungsweg bekommt man das Problem aber gelöst. Dann klappt’s auch mit dem Nachbarn oder besser gesagt mit AntispamBee  😉

CommentLuv ohne AntispamBee
CommentLuv ohne AntispamBee
CommentLuv mit AntispamBee
CommentLuv mit AntispamBee

Für eine größere Ansicht der Bilder, bitte auf das entsprechende Bild klicken! (dieses öffnet sich dann in einem neuen Tab/Fenster) Sergej Müller habe ich davon auch bereits in Kenntnis gesetzt, wobei ich denke dass es ihm vielleicht sogar egal sein wird. Weil es ja nichts schlimmes anrichtet und er es sicherlich nicht extra ändern wird. Aber falls noch jemand mal wegen diesem Problem bei ihm anfragt, weiß er jetzt auf jeden Fall bescheid. Sorry Sergej nochmal für die vielen Mails, aber ich wollte dich nur auf dem Laufenden halten.  😳

4 Antworten auf „CommentLuv Problem mit AntispamBee – LÖSUNG“

  1. Habe momentan auch ein Problem mit ComentLuv. Immer wenn ich einen Kommentar auf einen Blog abgeben möchte fängt mein Browser an eine Datei zu downloaden. Jetzt weiß ich aber nicht, ob es an den Blogs liegt, auf denen ich komentieren möchte oder ob das Problem bei meinem Blog liegt.

    Mal sehen ob es hier funktioniert. Wenn, dann lag es an den anderen Blogs.

    LG Gregor

  2. Hallo Gregor, und danke für deine zwei netten Kommentare. Ich freu mich, dass du dein CommentLuv Problem auch gelöst bekommen hast. Soso, dann lag’s also doch nicht an deinem Blog sondern an deinem PC. Interessant…

  3. Hallo Jörg, ich habe jetzt bestimmt zwei Stunden gesucht um genau dieses Problem zu lösen. Nachdem Update des Plugins wusste ich die Einstellung nicht mehr. Also trat o. g. Problem natürlich wieder auf. Besten Dank für den Tipp, ich war letztendlich dabei es zu deaktivieren. Gruß Daniel

Schreibe einen Kommentar